We will checkout the most common problems and solutions arising during usage of MK2A, MK2B and MK3 heatbed for 3D Printer and RepRap. In our experience 80% of the time software configuration will be the root cause. Even new replacement will behave in same way. We will walk you through most common problems with heatbeds and troubleshooting technicians are listed here, by following this you will be able to uncover the issue easily.

Heat Bed Resistance Check

  • Unwire and Measure the resistance of Heat bed at solder point with Multi Meter. Should not be more than 1.5ohm
  • Unwire and Measure the resistance of Heat bed at between two wire with Multi Meter (Should not be more than 1.5ohm also should not have more variation than solder point resistance)

Thermistor issue

  • Wrong thermistor table can give wrong heating
  • In Marlin firmware the list of supported thermistor can be found in file Marlin/thermistortables.h
  • Thermistor damaged Check heatbed thermistor circuit is OK?
  • Check temperature reading in your host software (repetierhost, pronterface etc), room temperature (29-35 C) should be displayed when the heatbed is off and cold

Testing Heatbed

  • If you see the thermistor is still OK, but still heatbed is not working as expected
  • Disconnect the heatbed from RAMPS
  • Connect the heat bed directly to power supply (DC 12V 10A) (Still Thermistor connected to RAMPS, so you can monitor the temperature in host software repitier host)
  • Turn on the power supply and check the temperature rise, If the heatbeds temperature rises as expected.
  • Then you can conclude the heatbed is working expected.
  • You will want to check the other electronics or software configuration.

Cables wear/tear/burn

  • Wire should be able to carry 10A current
  • If you are extending the wire then please check, wires capability and resistance.
  • If you suspect wire issue, rewiring with stronger cables for heatbed

Wrong Wiring

  • Are the heat bed wired to correct terminal (Depends on the firmware configuration)

RepRap 3DPrinter Heatbed Troubleshooting Guide

There is one for the 5 amp side of the power connector and one for the 11 amp side of the connector. The 11A one is what powers your heat bed(larger one.) Use a multimeter to figure out which one has a leg connected to the plus side of the 11A power connector. Once you have identified which one it is check across the leads of this one. It should read almost no resistance. If it has something like 100K then it's probably the issue. If has next to no resistance, then you probably need to check the three legged mosfet transistor. I believe it's the one closest to the power connector. If your lucky your RAMPS builder put a heat sink on it. It's usually the only one with a heat sink. The RAMPS page has a schematic and should help you with your trouble shooting.

Electronics Damaged

  • Also Check the melt/burn in wiring terminal of Electronic controller board (RAMPS, RUMBA, etc..)

Heatbed Temperature not Constant

  • Check the temperature graph, you see it is not normal - Do a PID tuning for heat bed.

Fuse damage in RAMPS

  • There are two self resting fuses on the ramps board. It's those two yellowish things that look like large flat ceramic capacitors. You could have damaged one of those such that is can't reset it's self.
  • The heat bed fuse commonly shuts down if un-cooled - get a small fan aimed at the yellow polyfuses

Not Enough Power Supply

  • Check the power supply - Should have at lease 12V 20A Power supply to run Heat bed
  • Input to RAMPS should be 12V (11.5-13V)
  • Measure output when wired and head bed is turned on via host controller (like repetier hots, etc)
  • Measure the power at output, and both inputs of RAMPS, that should read 12V.

How much power do the Head bed need?

  I=V/R, I = 12 / (Measure Resistance)
Location/Terminal Expected Volt (approx)
Power supply (12V)
RAMPS (INPUT) (12V)
MOSFET/D8 Output(12V)
Heated Bed (0.2V)(2ohm)